<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en, sv" />
<meta name="viewport" content="width=device-width" /> 			<script type="text/javascript">
			var addToHomeConfig = {
			expire: 10000,
			touchIcon: true
		};
		</script>
		<link rel="stylesheet" href="https://everettclipper.com/wp-content/themes/snoflex/tools/addtohome/add2home.css">
		<script type="application/javascript" src="https://everettclipper.com/wp-content/themes/snoflex/tools/addtohome/add2home.js"></script>
		<meta name="apple-mobile-web-app-capable" content="yes">
	<link rel="apple-touch-icon" href="https://everettclipper.com/wp-content/uploads/2016/09/twitterlogowhite.jpg" /><link rel="Shortcut Icon" href="https://everettclipper.com/wp-content/uploads/2016/09/twitterlogowhite.jpg" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="The Clipper RSS 2.0" href="https://everettclipper.com/feed/" />
<link rel="alternate" type="text/xml" title="The Clipper RSS .92" href="https://everettclipper.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="The Clipper Atom 0.3" href="https://everettclipper.com/feed/atom/" />

<title>Quarterly Financial Assistance Offered to EvCC International Students &#8211; The Clipper</title>
<link rel="alternate" type="application/rss+xml" title="The Clipper &raquo; Quarterly Financial Assistance Offered to EvCC International Students Comments Feed" href="https://everettclipper.com/13181/showcase/quarterly-financial-assistance-offered-to-evcc-international-students/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/everettclipper.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			<style type="text/css">
				</style>
	<link rel='stylesheet' id='farbtastic-css'  href='https://everettclipper.com/wp-admin/css/farbtastic.min.css?ver=1.3u1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://everettclipper.com/wp-includes/css/dashicons.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://everettclipper.com/wp-includes/js/thickbox/thickbox.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://everettclipper.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://everettclipper.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://everettclipper.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://everettclipper.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://everettclipper.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://everettclipper.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.5' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=PT+Sans+Narrow%3A400%2C700%7CRosario%3A400%2C700%7CRoboto%3A400%2C700%7CAsap%3A400%2C700&#038;display=swap&#038;ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://everettclipper.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20191203' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://everettclipper.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://everettclipper.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://everettclipper.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://everettclipper.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://everettclipper.com/wp-content/themes/snoflex/style.css?ver=20200596' type='text/css' media='all' />
<link rel='stylesheet' id='wp-paginate-css'  href='https://everettclipper.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.0.8' type='text/css' media='screen' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://everettclipper.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=20190826'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/everettclipper.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20200505'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.4.2'></script>
<link rel='https://api.w.org/' href='https://everettclipper.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://everettclipper.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://everettclipper.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Anxiety Caused by COVID-19 and Tips on How to Handle It' href='https://everettclipper.com/13172/showcase/anxiety-caused-by-covid-19-and-tips-on-how-to-handle-it/' />
<link rel='next' title='A Letter From the Editor: Daniel Albert' href='https://everettclipper.com/13204/showcase/a-letter-from-the-editor-daniel-albert/' />
<meta name="generator" content="WordPress 5.4.2" />
<link rel="canonical" href="https://everettclipper.com/13181/showcase/quarterly-financial-assistance-offered-to-evcc-international-students/" />
<link rel='shortlink' href='https://everettclipper.com/?p=13181' />
<link rel="alternate" type="application/json+oembed" href="https://everettclipper.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feverettclipper.com%2F13181%2Fshowcase%2Fquarterly-financial-assistance-offered-to-evcc-international-students%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://everettclipper.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feverettclipper.com%2F13181%2Fshowcase%2Fquarterly-financial-assistance-offered-to-evcc-international-students%2F&#038;format=xml" />


<!-- Start of Facebook Meta Tags -->

<meta property="og:title" content="Quarterly Financial Assistance Offered to EvCC International Students" />
<meta property="og:type" content="article" />
<meta name="author" content="Jade Phan" />
<meta property="og:url" content="https://everettclipper.com/13181/showcase/quarterly-financial-assistance-offered-to-evcc-international-students/" />
<meta property="og:image" content="https://everettclipper.com/wp-content/uploads/2020/06/Visakan-Ganeson-High-Resolution-900x600.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="600" />
	<meta property="og:site_name" content="The Clipper" />
	<meta property="og:description" content="In light of the COVID-19 crisis, which leads to many insecurities and confusion among international students in Washington, EvCC International Education Department has created a $45,000 grant to support international students. Understanding the very unique fears, challenges and concerns of those students during this unprecedented time, EvCC has decided to give away $45,000 from the..." />
	<meta name="description" content="In light of the COVID-19 crisis, which leads to many insecurities and confusion among international students in Washington, EvCC International Education Department has created a $45,000 grant to support international students. Understanding the very unique fears, challenges and concerns of those students during this unprecedented time, EvCC has decided to give away $45,000 from the..." />
	<meta property="article:section" content="News" />
	<meta property="article:tag" content="EvCC Foundation,Financial Aid,International" />
<!-- End of Facebook Meta Tags -->



<script>
	jQuery(document).ready(function() {
		var wpadminbar = jQuery('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if (jQuery('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
				jQuery('.subnavbarwrap').scrollToFixed({
			marginTop:  wpadminbar,
		});		
		
		
		
	
	});
</script>


<style type="text/css" media="screen">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</style>
</head>

<body data-rsssl=1><div id="alt_wrap"><div class="clear"></div><div id="altheader"><div id="altheader-left-main" class="altheader-left hidethis"><div class="altheader-menu"><div class="alt_mobile_menu_icon"><div class="mobile_menu_icon_bar"></div><div class="mobile_menu_icon_bar"></div><div class="mobile_menu_icon_bar"></div><div class="mobile_menu_text">MENU</div></div></div><div class="altheader-logo"><a href="https://everettclipper.com"><img src="https://everettclipper.com/wp-content/uploads/2018/03/name.logo_.jpg" alt="The student news site of Everett Community College in Everett, Washington" /></a></div></div><div class="altheader-right"><div class="altheader-bar1"><div class="altheader-right-social"><div class="alt-header-social-bar">        					<a onclick="window.open('http://feedburner.google.com/fb/a/mailverify?uri=TheClipper', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true" href="#"><div class="alt-header-social social-border sno-email dashicons dashicons-email-alt"></div></a>
							<a target="_blank" href="https://www.instagram.com/everettclipper/">
        						<div class="alt-header-social-fa social-border sno-instagram fa fa-instagram"></div>
        					</a><a target="_blank" href="https://twitter.com/EverettClipper">
        						<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"></div>
        					</a><a target="_blank" href="https://www.facebook.com/pages/The-Clipper/144917002154?ref=hl">
        						<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"></div>
        					</a><div class="alt-header-social-spacer"></div></div><div id="sno-search-wrap"><form method="get" id="searchform-alt2" action="https://everettclipper.com/"><div id="sno-search" class="alt-header-social sno-search fa fa-search"></div><div style="position:relative;line-height:30px;" class="alt-header-social"><div id="expandable-search-box"><label for="s-alt2" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt2" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt2" style="display:none" value="Search" />
											<button type="submit" id="sno-search-button" class="alt-header-social sno-search fa fa-search"></button>
</div></div><div class="alt-header-search-bar"></div></form></div><script type="text/javascript">
					jQuery(window).load(function() {
					
						resizeSearch();

					})
					jQuery(window).resize(function() {
						resizeSearch();
					});

					function resizeSearch() {
													var leftEdge = jQuery('#altheader-left-main').width();
												var rightEdge = jQuery('.sno-search').offset().left;
						rightEdge = rightEdge.toFixed(0);
						var searchWidth = rightEdge - leftEdge;
												jQuery("#expandable-search-box").width(searchWidth);    				
						 

					}

    				jQuery("input#s-alt").focus(function(){
    					document.getElementById("s-alt2").style.backgroundColor="#ddd";
    					document.getElementById("s-alt2").style.color="#444";
    					document.getElementById("sno-search-button").style.backgroundColor="#ddd";
    					document.getElementById("sno-search-button").style.color="#444";
    					jQuery('#sno-search').hide();
    					if(jQuery('#sno-search-button').is(':hidden')) {
    						var searchWidth = jQuery('#expandable-search-box').width();
    						jQuery('.altheader-right #expandable-search-box').width(searchWidth + 40);
    						jQuery('.altheader-top #expandable-search-box').width(searchWidth + 30);
    					}
    					jQuery('#sno-search-button').show();
					});

					jQuery("#sno-search").click(function(){
    					document.getElementById("sno-search-button").style.backgroundColor="#ddd";
    					document.getElementById("sno-search-button").style.color="#444";
    					jQuery('#s-alt2').focus();
					});
					
					if (jQuery('#sno-search').offset().left < 405) { 
						jQuery('#sno-search-wrap').hide();
						jQuery('.altheader-right-social').css({ background: "" });
					}
					
    			</script> </div></div><div class="altheader-bar2"><div id="subnavbar"><div id="subnavbarbackground"><ul id='show-mini-logo-bottom'  style="display:none" ><a href="/"><li id="mini-logo-bottom" style="float:left;"><img src="https://everettclipper.com/wp-content/uploads/2016/09/twitterlogowhite.jpg" alt="The student news site of Everett Community College in Everett, Washington" />
							</li></a>
						</ul><div id="menu-b-menu"><div class="menu-main-navigation-container"><ul id="menu-main-navigation" class="sf-menu alt-b"><li id="menu-item-6452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-6452"><a href="https://everettclipper.com">Home</a></li>
<li id="menu-item-6210" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-6210"><a href="https://everettclipper.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-10454" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10454"><a href="https://everettclipper.com/category/community-news-beyond-campus/">Community News: Beyond Campus</a></li>
	<li id="menu-item-7693" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7693"><a href="https://everettclipper.com/category/lrc/">Learning Resource Center</a></li>
</ul>
</li>
<li id="menu-item-6807" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6807"><a href="https://everettclipper.com/category/video/">Video</a></li>
<li id="menu-item-710" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-710"><a href="https://everettclipper.com/category/sports/">Sports</a></li>
<li id="menu-item-4132" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4132"><a href="https://everettclipper.com/category/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-8156" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8156"><a href="https://everettclipper.com/category/culture/">Culture</a></li>
	<li id="menu-item-8157" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8157"><a href="https://everettclipper.com/category/spotlight/">Spotlight</a></li>
	<li id="menu-item-8158" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8158"><a href="https://everettclipper.com/category/tips-and-tricks/">Tips and Tricks</a></li>
	<li id="menu-item-8159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8159"><a href="https://everettclipper.com/category/stem/">STEM</a></li>
	<li id="menu-item-10450" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10450"><a href="https://everettclipper.com/category/entertainment/">Entertainment</a></li>
	<li id="menu-item-10451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10451"><a href="https://everettclipper.com/category/identity/">Identity</a></li>
	<li id="menu-item-10452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10452"><a href="https://everettclipper.com/category/culture/">Culture</a></li>
	<li id="menu-item-10453" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10453"><a href="https://everettclipper.com/category/lifestyle/">Lifestyle</a></li>
</ul>
</li>
<li id="menu-item-6922" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6922"><a href="https://everettclipper.com/staff/">Staff</a></li>
<li id="menu-item-6453" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6453"><a href="https://everettclipper.com/advertising/">Contact</a>
<ul class="sub-menu">
	<li id="menu-item-11777" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11777"><a href="https://everettclipper.com/advertising/2019-20-advertising-rate-sheet/">2019-20 Advertising Rate Sheet</a></li>
</ul>
</li>
<li id="menu-item-6921" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6921"><a href="https://everettclipper.com/about/">About</a></li>
</ul></div></div><ul id='menu-more' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
								<ul id="add-more" class="sub-menu"></ul>
								</li>
							</ul></div></div><script type="text/javascript">
					jQuery(document).ready(function() {
						resizeMenu();
					})
					jQuery(window).load(function() {
						resizeMenu();
					})
					
					function resizeMenu() {
						var moreWidth = 0; var menubuffer = 0; var minilogo = 0;
						if (jQuery('#menu-more').is(':visible')) { moreWidth = jQuery('#menu-more').width(); }			

													menubuffer = 1;
																			minilogo = jQuery('#mini-logo-bottom').width();
						
						if ((jQuery('#menu-b-menu').width() + minilogo + moreWidth + menubuffer) > (jQuery(window).width() - 326)) 
						{ 
							jQuery('.alt-b > li:last-child').addClass('sub-menu'); 
							jQuery('.alt-b > li:last-child').appendTo('#add-more'); 
							if (jQuery('#menu-more').is(':hidden')) { jQuery('#menu-more').css({display: "block"}); }			
							resizeMenu(); 
						} 
						 
					}
					
					jQuery(window).scroll(function() {
						resizeMenu();
					});
            		jQuery( window ).resize(function() { 
             	   		if (jQuery( window).width() > 980) { resizeMenu(); };
            		});   

 				</script></div></div></div><div id="fullwrap" style="position:relative;"><div id="outerbackgroundwrap"><div id="altheader-searchbox"><ul class="slidemenu mobile-menu"><div class="altheader-left menu-altheader"><div class="altheader-menu"><div class="alt_mobile_menu_icon"><div class="mobile_menu_icon_bar"></div><div class="mobile_menu_icon_bar"></div><div class="mobile_menu_icon_bar"></div><div class="mobile_menu_text">MENU</div></div></div><div class="altheader-logo altheader-logo-menu"><a href="https://everettclipper.com"><img src="https://everettclipper.com/wp-content/uploads/2018/03/name.logo_.jpg" alt="The student news site of Everett Community College in Everett, Washington" /></a></div></div><div class="clear"></div><div class="border-spacer"></div><li class="mobile-search"><form method="get" id="searchform-alt3" action="https://everettclipper.com/">
									<label for="s-alt3" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt3" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" id="searchsubmit-alt3" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-main-navigation-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-6452"><a href="https://everettclipper.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-6210"><a href="https://everettclipper.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10454"><a href="https://everettclipper.com/category/community-news-beyond-campus/">Community News: Beyond Campus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7693"><a href="https://everettclipper.com/category/lrc/">Learning Resource Center</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6807"><a href="https://everettclipper.com/category/video/">Video</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-710"><a href="https://everettclipper.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4132"><a href="https://everettclipper.com/category/features/">Features</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8156"><a href="https://everettclipper.com/category/culture/">Culture</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8157"><a href="https://everettclipper.com/category/spotlight/">Spotlight</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8158"><a href="https://everettclipper.com/category/tips-and-tricks/">Tips and Tricks</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8159"><a href="https://everettclipper.com/category/stem/">STEM</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10450"><a href="https://everettclipper.com/category/entertainment/">Entertainment</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10451"><a href="https://everettclipper.com/category/identity/">Identity</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10452"><a href="https://everettclipper.com/category/culture/">Culture</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10453"><a href="https://everettclipper.com/category/lifestyle/">Lifestyle</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6922"><a href="https://everettclipper.com/staff/">Staff</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6453"><a href="https://everettclipper.com/advertising/">Contact</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11777"><a href="https://everettclipper.com/advertising/2019-20-advertising-rate-sheet/">2019-20 Advertising Rate Sheet</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6921"><a href="https://everettclipper.com/about/">About</a></li>
</ul></div></ul></div><script type="text/javascript">
    			jQuery(".alt_mobile_menu_icon").click(function(){
				    jQuery("#altheader-searchbox").toggle('slow');
				    jQuery("body").toggleClass('noscroll');
						var $leftcolumn = jQuery('.innerbackground');
							var homeLeft = $leftcolumn.offset().left;
					jQuery("#footer").animate({ marginLeft: homeLeft + "px"}); 
					
				});  
				
								if (jQuery('.slidemenu').is(":visible")) {
									jQuery('.hidethis').css({ visibility: "hidden" });
									jQuery('#altheader-searchbox').css({ zIndex: "1001"});
								} else {
									jQuery('.hidethis').css({ visibility: "visible" });
									jQuery('#altheader-searchbox').css({ zIndex: "99"});
								}


    		</script><script type="text/javascript">
									
			</script><div class="innerbackgroundwrap"><div class="innerbackground"><div id='snopostid-13181' class='snopostid'><div id='storypage' class='full-width sno-story-13181'><div id="content"><div id='contentleft'><div class="postarea"><div role="main"><h1 id="storyheadline" class="storyheadline">Quarterly Financial Assistance Offered to EvCC International Students</h1><div class="storydeckbottom"></div><div class="storydeck"><p>A $45,000 Grant Has Been Funded by the EvCC Foundation to Help International Students Impacted by the COVID-19 Pandemic</p></div><div id="storymeta" class="storymeta"><p> <a href="https://everettclipper.com/staff_profile/jade-phan/" class="creditline">Jade Phan</a>, Staff Writer<span class="storydate"><span class="byline-divider">|</span><span class="time-wrapper">June 17, 2020</span></span></p></div><div class="permalinkphotobox"><div class="storyshadow"><div class="photowrap"><a class='modal-photo photooverlay' data-story-id='13181' data-photo-id='13183' href='#photo'><img src='https://everettclipper.com/wp-content/uploads/2020/06/Visakan-Ganeson-High-Resolution-900x600.jpg' alt='Associate+Vice-President+of+EvCC+International+Education+Department+Visakan+Ganeson.+%E2%80%9CInternational+students+are+in+the+same+situation+as+the+domestic+students%2C+because+this+is+the+world+crisis%2C%E2%80%9D+says+Ganeson.' style='width:100%' class='catboxphoto feature-image' /></a><div class='modal-photo photo-enlarge elusive el-icon-zoom-in' data-story-id='13181' data-photo-id='13183'></div></div><div class="clear"></div><div class="captionboxmit"><p class="photocredit">Courtesy photo from Visakan Ganeson</p><p class="photocaption">Associate Vice-President of EvCC International Education Department Visakan Ganeson. “International students are in the same situation as the domestic students, because this is the world crisis,” says Ganeson.</p></div></div><div class='snoadnetwork'>
	<div class='advertisementwrap'>
		<div class='sidebar-ad'>
			<script type="text/javascript">
				jQuery(document).ready(function( $ ) {
					retreive_ad();
					$('.sidebar-ad').on('click', '.sno-ad', function() {
						let ad_id = $(this).data('ad-id');
						url = 'https://snoads.com/api/v1/ad/' + ad_id + '/click';
						jQuery.post(url, '', function(response) {
							console.log(response);
				        });
					});

					$('.sidebar-ad').on('click', '.sno-fill-ad', function() {
						url = 'https://snoads.com/site/344';
						window.open(url, '_blank');
					});

			        function retreive_ad() {
			        	var url = 'https://snoads.com/api/v1/adspot/481/serve'
			        	var fill_ad = "";
						jQuery.get(url, '', function(response) {
							if (response) {
								$('.sidebar-ad').html('<a target="_blank" href="' + response.link.link + '" class="sno-ad" data-ad-id="' + response.id + '"><img src="' + response.image.url + '" /></a>');
							} else if (fill_ad) {
								$('.sidebar-ad').html('<img class="sno-fill-ad" src="' + fill_ad + '" />');
							} else {
								let rand_num = Math.floor((Math.random() * 2) + 1);
								$('.sidebar-ad').html('<img class="sno-fill-ad" src="https://snoads.s3.amazonaws.com/sno_ad_fill/300x250_' + rand_num + '.jpg" />');
							}
				        });
			        }
				});
			</script>
		</div>
	</div>
</div>
<div class="clear"></div></div><div class="sharing sharing-top" data-story-id="13181"><a class='commentscroll' href='https://everettclipper.com/13181/showcase/quarterly-financial-assistance-offered-to-evcc-international-students/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-hide'><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Feverettclipper.com%2F13181%2Fshowcase%2Fquarterly-financial-assistance-offered-to-evcc-international-students%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Quarterly Financial Assistance Offered to EvCC International Students&amp;url=https%3A%2F%2Feverettclipper.com%2F%3Fp%3D13181" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//everettclipper.com/13181/showcase/quarterly-financial-assistance-offered-to-evcc-international-students//?print=true"><div class="sharing-icon sno-print fa fa-print sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Print</span></div></a></div><span class="storycontent"><p><span style="font-weight: 400;">In light of the COVID-19 crisis, which leads to many insecurities and confusion among international students in Washington, EvCC International Education Department has created a $45,000 grant to support international students.</span></p>
<p><span style="font-weight: 400;">Understanding the very unique fears, challenges and concerns of those students during this unprecedented time, EvCC has decided to give away $45,000 from the EvCC foundation to 60 students in the form of financial assistance awards, which are $750 each, for the next three quarters, beginning with Spring 2020.</span></p>
<p><span style="font-weight: 400;">To international students who are away from home during this pandemic, the chaos caused by the COVID-19 crisis has left them insecure about having adequate housing or access to food and other essentials. Nhat Vo, an international student from Vietnam says, “Many of my international friends have missed their sources of income because of this pandemic, I feel lucky that I still have income from my part-time job to pay for my living expenses.”</span></p>
<p><span style="font-weight: 400;">Visakan Ganeson, Associate Vice-President of the International Education Department, says that the reason behind the decision to create this grant is because The Coronavirus Aid, Relief, and Economic Security Act, which is also known as the CARES Act, does not help international students when they are also going through tough situations caused by this crisis as much as the domestic students are. “This is a world crisis, so everyone is affected the same way,” says Ganerson.</span></p>
<p><span style="font-weight: 400;">International students hoping to receive the financial assistance awards needed to apply by May 21. Staff members of the International Education Office then went through an assessment to pick out 20 applicants to receive the financial assistance each quarter.</span></p>
<figure id="attachment_13184" aria-describedby="caption-attachment-13184" style="width: 353px" class="wp-caption alignleft"><img class=" wp-image-13184" src="https://everettclipper.com/wp-content/uploads/2020/06/102552323_270292130952965_2415786487786381203_n-475x356.jpg" alt="" width="353" height="265" srcset="https://everettclipper.com/wp-content/uploads/2020/06/102552323_270292130952965_2415786487786381203_n-475x356.jpg 475w, https://everettclipper.com/wp-content/uploads/2020/06/102552323_270292130952965_2415786487786381203_n-900x675.jpg 900w, https://everettclipper.com/wp-content/uploads/2020/06/102552323_270292130952965_2415786487786381203_n-768x576.jpg 768w, https://everettclipper.com/wp-content/uploads/2020/06/102552323_270292130952965_2415786487786381203_n-300x225.jpg 300w, https://everettclipper.com/wp-content/uploads/2020/06/102552323_270292130952965_2415786487786381203_n.jpg 1080w" sizes="(max-width: 353px) 100vw, 353px" /><figcaption id="caption-attachment-13184" class="wp-caption-text">EvCC international student from Vietnam, Nhat Vo, 18, says “It warms my heart so much because I know the staff is always here for us.&#8221; (Courtesy photo from Nhat Vo)</figcaption></figure>
<p><span style="font-weight: 400;">Vo, who is one of the recipients of the grant this Spring quarter, says that the award means so much to him, and the money is a big help during this unprecedented time. “I use the money to pay for my food, rent, as well as buying some textbooks for my summer quarter classes,” Vo says.</span></p>
<p><span style="font-weight: 400;">According to Ganeson, the college is doing its best to accommodate the special needs of its international students during this pandemic, but the grant cannot be the one solution to all the problems they are going through. “I hope the students will be able to find a long-term solution and the governments of their home countries will help them the same way as the U.S government is helping American people.” </span></p>
<p><span style="font-weight: 400;">Indeed, the grant cannot make all the insecurities and fears in those foreign students go away, but to some extent, it reminds the students that even though they don’t have a local family, they are not alone in this pandemic. Vo expresses his excitement about the grant, “I was so touched the moment I received the email about the grant, I am just so happy because it shows that during this challenging time, they still care for people like us.”</span></p>
</span></div><div class="clear"></div><ul class="snotags"><li class="blockstag"><a href="https://everettclipper.com/tag/evcc-foundation/" rel="tag">EvCC Foundation</a></li><li class="blockstag"><a href="https://everettclipper.com/tag/financial-aid/" rel="tag">Financial Aid</a></li><li class="blockstag"><a href="https://everettclipper.com/tag/international/" rel="tag">International</a></li></ul><div class="aboutwriter"><div class='aboutwritertitle'>About the Contributor</div>
<!-- profile displayed from cache -->
<div class='storycreditboxwide'><div class='sc_photo'><img src='https://everettclipper.com/wp-content/uploads/2020/05/06F16210-D9C2-448E-A1DE-209B19278593-356x475.jpeg' alt='Photo of Jade Phan'/></div><a href="https://everettclipper.com/staff_profile/jade-phan/"><div class='sc_title'>Jade Phan, Staff Writer</div></a><div class='sc_bio'><div class='clear'></div></div></div><div class="clear"></div></div><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div tabindex="0" role="button" aria-expanded="true" class="commenttoggle fa fa-minus-square"></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id='commentsbody' class='widgetbody' style='display:block;'>


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">

If you want a picture to show with your comment, go get a <a href="https://en.gravatar.com">gravatar</a>.</p>





<form action="https://everettclipper.com/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><label for="spam_stopper">Spam Control Field. Please Ignore</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							jQuery(function(){
								jQuery('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="13181" /></p>



<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2865290792" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="246"/></p>


</form>









</div></div><div class="widgetfooter"></div></div></div></div><div class="clear"></div><div class="relatedstories"><div class="storymeta" style="margin-bottom:0px;"><p style="text-align:center;font-size:16px;line-height:30px;"><a href="https://everettclipper.com/category/news/">News</a></p></div><div class="relatedbody"><div class='catrow catstory-position-1'><a href="https://everettclipper.com/13163/showcase/an-observation-of-seattles-capitol-hill-autonomous-zone/" title="An Observation of Seattle&#8217;s Capitol Hill Autonomous Zone"><img src="https://everettclipper.com/wp-content/uploads/2020/06/CHAZThumbnail-240x150.jpg" class="catstory-photo" alt="Banners reading "Remember Who We Are Fighting For" and "This Is Just The Beginning" are hung at Cal Anderson Park in the area of the Capitol Hill Occupied Protest (CHOP)." /></a><h5 class="relatedtitle"><a href="https://everettclipper.com/13163/showcase/an-observation-of-seattles-capitol-hill-autonomous-zone/">An Observation of Seattle&#8217;s Capitol Hill Autonomous Zone</a></h5></div><div class='relateddividervert catstory-position-2'></div><div class='catrow catstory-position-2'><a href="https://everettclipper.com/13111/showcase/speakers-share-personal-experiences-at-everett-blm-protest/" title="Speakers Share Personal Experiences at Everett BLM Protest"><img src="https://everettclipper.com/wp-content/uploads/2020/06/thumbnailEverettProtest-240x150.jpg" class="catstory-photo" alt="A crowd of peaceful protesters in front of the Everett Municipal Building gathered to hear from the protest’s speakers." /></a><h5 class="relatedtitle"><a href="https://everettclipper.com/13111/showcase/speakers-share-personal-experiences-at-everett-blm-protest/">Speakers Share Personal Experiences at Everett BLM Protest</a></h5></div><div class='relateddividervert catstory-position-3'></div><div class='catrow catstory-position-3'><a href="https://everettclipper.com/13120/showcase/how-evcc-is-affected-as-washington-moves-into-phase-2/" title="How EvCC Is Affected as Washington Moves Into Phase 2"><img src="https://everettclipper.com/wp-content/uploads/2020/06/face-mask-5024710_1920-240x150.jpg" class="catstory-photo" alt="As Washington enters phase 2, citizens are encouraged to continue wearing face coverings in public to prevent the spread of COVID-19." /></a><h5 class="relatedtitle"><a href="https://everettclipper.com/13120/showcase/how-evcc-is-affected-as-washington-moves-into-phase-2/">How EvCC Is Affected as Washington Moves Into Phase 2</a></h5></div><div class='relateddividervert catstory-position-4'></div><div class='catrow catstory-position-4'><a href="https://everettclipper.com/13106/news-features/a-conversation-with-local-black-lives-matter-activist-sierra-taylor/" title="A Conversation with Local Black Lives Matter Activist Sierra Taylor"><img src="https://everettclipper.com/wp-content/uploads/2020/06/IMG_0089-240x150.jpeg" class="catstory-photo" alt="Local BLM activist, Sierra Taylor." /></a><h5 class="relatedtitle"><a href="https://everettclipper.com/13106/news-features/a-conversation-with-local-black-lives-matter-activist-sierra-taylor/">A Conversation with Local Black Lives Matter Activist Sierra Taylor</a></h5></div><div class='relateddividervert catstory-position-5'></div><div class='catrow catstory-position-5'><a href="https://everettclipper.com/13100/showcase/evcc-eliminates-85-part-time-hourly-positions/" title="EvCC Eliminates 85 Part-Time Hourly Positions"><img src="https://everettclipper.com/wp-content/uploads/2020/06/graywolffull-240x150.jpg" class="catstory-photo" alt="The Gray Wolf Hall  building on EvCC's campus." /></a><h5 class="relatedtitle"><a href="https://everettclipper.com/13100/showcase/evcc-eliminates-85-part-time-hourly-positions/">EvCC Eliminates 85 Part-Time Hourly Positions</a></h5></div><div class="clear"></div></div></div><div class="clear"></div><div class="relatedstories"><div class="storymeta" style="margin-bottom:0px;"><p style="text-align:center;font-size:16px;line-height:30px;"><a href="https://everettclipper.com/category/recent-stories/">Recent Stories</a></p></div><div class="relatedbody"><div class='catrow catstory-position-1'><a href="https://everettclipper.com/13204/showcase/a-letter-from-the-editor-daniel-albert/" title="A Letter From the Editor: Daniel Albert"><img src="https://everettclipper.com/wp-content/uploads/2020/04/daniel-720x900-1-240x150.jpg" class="catstory-photo" alt="The Clipper's current Editor in Chief, Daniel Albert." /></a><h5 class="relatedtitle"><a href="https://everettclipper.com/13204/showcase/a-letter-from-the-editor-daniel-albert/">A Letter From the Editor: Daniel Albert</a></h5></div><div class='relateddividervert catstory-position-2'></div><div class='catrow catstory-position-2'><a href="https://everettclipper.com/13172/showcase/anxiety-caused-by-covid-19-and-tips-on-how-to-handle-it/" title="Anxiety Caused by COVID-19 and Tips on How to Handle It"><img src="https://everettclipper.com/wp-content/uploads/2020/06/anxiety-2019928_1920-240x150.jpg" class="catstory-photo" alt="Anxiety Caused by COVID-19 and Tips on How to Handle It" /></a><h5 class="relatedtitle"><a href="https://everettclipper.com/13172/showcase/anxiety-caused-by-covid-19-and-tips-on-how-to-handle-it/">Anxiety Caused by COVID-19 and Tips on How to Handle It</a></h5></div><div class='relateddividervert catstory-position-3'></div><div class='catrow catstory-position-3'><a href="https://everettclipper.com/13176/showcase/how-the-covid-19-pandemic-is-bringing-families-closer-together/" title="How the COVID-19 Pandemic is Bringing Families Closer Together"><img src="https://everettclipper.com/wp-content/uploads/2020/06/fam-240x150.jpg" class="catstory-photo" alt="Sharon Hale, 73, (seen at the bottom of the Zoom call screen) has been volunteering in EvCC’s BRIDGES Center for 4 years, and has been spending time with her family over Zoom during quarantine. " /></a><h5 class="relatedtitle"><a href="https://everettclipper.com/13176/showcase/how-the-covid-19-pandemic-is-bringing-families-closer-together/">How the COVID-19 Pandemic is Bringing Families Closer Together</a></h5></div><div class='relateddividervert catstory-position-4'></div><div class='catrow catstory-position-4'><a href="https://everettclipper.com/13166/showcase/we-dont-talk-about-black-women-enough-a-speech-by-sophia-tekola/" title="We Don&#8217;t Talk About Black Women Enough: A Speech by Sophia Tekola"><img src="https://everettclipper.com/wp-content/uploads/2020/06/blmspd-240x150.jpg" class="catstory-photo" alt="The abandoned Seattle Police Department East Precinct on Capitol Hill, defaced as the "Seattle People Department East Precinct" decorated with a sign that reads "Power & Equality"." /></a><h5 class="relatedtitle"><a href="https://everettclipper.com/13166/showcase/we-dont-talk-about-black-women-enough-a-speech-by-sophia-tekola/">We Don&#8217;t Talk About Black Women Enough: A Speech by Sophia Tekola</a></h5></div><div class='relateddividervert catstory-position-5'></div><div class='catrow catstory-position-5'><a href="https://everettclipper.com/13163/showcase/an-observation-of-seattles-capitol-hill-autonomous-zone/" title="An Observation of Seattle&#8217;s Capitol Hill Autonomous Zone"><img src="https://everettclipper.com/wp-content/uploads/2020/06/CHAZThumbnail-240x150.jpg" class="catstory-photo" alt="Banners reading "Remember Who We Are Fighting For" and "This Is Just The Beginning" are hung at Cal Anderson Park in the area of the Capitol Hill Occupied Protest (CHOP)." /></a><h5 class="relatedtitle"><a href="https://everettclipper.com/13163/showcase/an-observation-of-seattles-capitol-hill-autonomous-zone/">An Observation of Seattle&#8217;s Capitol Hill Autonomous Zone</a></h5></div><div class="clear"></div></div></div><div class="clear"></div></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://everettclipper.com/13163/showcase/an-observation-of-seattles-capitol-hill-autonomous-zone/#photo'><img src='https://everettclipper.com/wp-content/uploads/2020/06/CHAZThumbnail-475x317.jpg' id='grow-stb13163'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Banners reading "Remember Who We Are Fighting For" and "This Is Just The Beginning" are hung at Cal Anderson Park in the area of the Capitol Hill Occupied Protest (CHOP).'/></a></div><p class='stb-cat'>Community News: Beyond Campus</p><p class="relatedtitle"><a href="https://everettclipper.com/13163/showcase/an-observation-of-seattles-capitol-hill-autonomous-zone/">An Observation of Seattle&#8217;s Capitol Hill Autonomous Zone</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://everettclipper.com/13111/showcase/speakers-share-personal-experiences-at-everett-blm-protest/#photo'><img src='https://everettclipper.com/wp-content/uploads/2020/06/thumbnailEverettProtest-475x356.jpg' id='grow-stb13111'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='A crowd of peaceful protesters in front of the Everett Municipal Building gathered to hear from the protest’s speakers.'/></a></div><p class='stb-cat'>Community News: Beyond Campus</p><p class="relatedtitle"><a href="https://everettclipper.com/13111/showcase/speakers-share-personal-experiences-at-everett-blm-protest/">Speakers Share Personal Experiences at Everett BLM Protest</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://everettclipper.com/13120/showcase/how-evcc-is-affected-as-washington-moves-into-phase-2/#photo'><img src='https://everettclipper.com/wp-content/uploads/2020/06/face-mask-5024710_1920-475x317.jpg' id='grow-stb13120'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='As Washington enters phase 2, citizens are encouraged to continue wearing face coverings in public to prevent the spread of COVID-19.'/></a></div><p class='stb-cat'>Community News: Beyond Campus</p><p class="relatedtitle"><a href="https://everettclipper.com/13120/showcase/how-evcc-is-affected-as-washington-moves-into-phase-2/">How EvCC Is Affected as Washington Moves Into Phase 2</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://everettclipper.com/13106/news-features/a-conversation-with-local-black-lives-matter-activist-sierra-taylor/#photo'><img src='https://everettclipper.com/wp-content/uploads/2020/06/IMG_0089-356x475.jpeg' id='grow-stb13106'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Local BLM activist, Sierra Taylor.'/></a></div><p class='stb-cat'>Community News: Beyond Campus</p><p class="relatedtitle"><a href="https://everettclipper.com/13106/news-features/a-conversation-with-local-black-lives-matter-activist-sierra-taylor/">A Conversation with Local Black Lives Matter Activist Sierra Taylor</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://everettclipper.com/13100/showcase/evcc-eliminates-85-part-time-hourly-positions/#photo'><img src='https://everettclipper.com/wp-content/uploads/2020/06/graywolffull-475x380.jpg' id='grow-stb13100'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The Gray Wolf Hall  building on EvCC's campus.'/></a></div><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://everettclipper.com/13100/showcase/evcc-eliminates-85-part-time-hourly-positions/">EvCC Eliminates 85 Part-Time Hourly Positions</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://everettclipper.com/13094/showcase/black-lives-matter-protest-in-downtown-everett/#photo'><img src='https://everettclipper.com/wp-content/uploads/2020/06/evccdeans-377x475.jpg' id='grow-stb13094'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Deans of EvCC were in attendance at the peaceful Black Lives Matter protest in downtown Everett on Jun. 6, 2020. They wore shirts and held signs that said "EvCC Deans For #BlackLivesMatter".'/></a></div><p class='stb-cat'>Community News: Beyond Campus</p><p class="relatedtitle"><a href="https://everettclipper.com/13094/showcase/black-lives-matter-protest-in-downtown-everett/">Black Lives Matter Protest in Downtown Everett</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://everettclipper.com/13066/news-features/evcc-partners-with-volunteers-of-america-western-washington/#photo'><img src='https://everettclipper.com/wp-content/uploads/2020/06/Cory-Helping-Same-Car-e1591227428787-356x475.jpg' id='grow-stb13066'  style='width:70px;min-width:70px;' class='catboxphoto' alt='VOA Director of Marketing and Communications, Cory Armstrong-Hoss (Middle) speaking with someone as volunteers load boxes of food into their trunk at the drive-through food bank distribution site in parking lot J of EvCC’s main campus on Wednesday, Jun. 3 to help stop food insecurity around Snohomish County.'/></a></div><p class='stb-cat'>Community News: Beyond Campus</p><p class="relatedtitle"><a href="https://everettclipper.com/13066/news-features/evcc-partners-with-volunteers-of-america-western-washington/">EvCC Partners with Volunteers of America Western Washington</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://everettclipper.com/13063/showcase/an-interview-with-a-black-lives-matter-protester/#photo'><img src='https://everettclipper.com/wp-content/uploads/2020/06/blmprotest-475x315.jpg' id='grow-stb13063'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Black Lives Matter protesters marching down the streets of downtown Seattle on May 30, 2020. One of them holds a sign that says "say his name", in reference to the police brutality case of George Floyd. '/></a></div><p class='stb-cat'>Community News: Beyond Campus</p><p class="relatedtitle"><a href="https://everettclipper.com/13063/showcase/an-interview-with-a-black-lives-matter-protester/">An Interview with a Black Lives Matter Protester</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://everettclipper.com/13060/showcase/a-closer-look-at-the-seattle-black-lives-matter-protests/#photo'><img src='https://everettclipper.com/wp-content/uploads/2020/06/blmprotest2-475x315.jpg' id='grow-stb13060'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Black Lives Matter protester holds a sign saying "hold whites and police accountable", on May 30, 2020.'/></a></div><p class='stb-cat'>Community News: Beyond Campus</p><p class="relatedtitle"><a href="https://everettclipper.com/13060/showcase/a-closer-look-at-the-seattle-black-lives-matter-protests/">A Closer Look at the Seattle Black Lives Matter Protests</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://everettclipper.com/13051/showcase/black-lives-matter-protest-in-seattle/#photo'><img src='https://everettclipper.com/wp-content/uploads/2020/05/BLM-thumbnail-475x310.jpg' id='grow-stb13051'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Black Lives Matter Protest in Seattle'/></a></div><p class='stb-cat'>Community News: Beyond Campus</p><p class="relatedtitle"><a href="https://everettclipper.com/13051/showcase/black-lives-matter-protest-in-seattle/">Black Lives Matter Protest in Seattle</a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		jQuery(document).ready(function() {
			jQuery('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: jQuery(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 250,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

  							//		animation: 'fade',
  							//		smoothHeight: false,
  							//		customDirectionNav: jQuery("#sfi-navigation span"),
  							//		animationLoop: true,
  							//		slideshow: false,
  							//		touch: true



		});

			jQuery(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			jQuery(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if (jQuery('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = jQuery(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && jQuery(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if (jQuery('.sno_teaserbar').is(":hidden")) {
						jQuery('.sno_teaserbar').show();
						jQuery('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && jQuery(document).scrollTop() > 500) || jQuery(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					jQuery('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							jQuery('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script></div></div></div></div><div style="clear:both;"></div><div class="footerwrap"><div id="footer"><div class="footername"><div class="footerleft"><p><a href="https://everettclipper.com">The Clipper</a></p></div><div class="footerright social-classic"><style>.topnavbarleft { padding: 0px; width:auto; }</style>        		<a onclick="window.open('http://feedburner.google.com/fb/a/mailverify?uri=TheClipper', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true" href="#">
        			<div class="alt-header-social social-border sno-email dashicons dashicons-email-alt"><span class="icon-hidden-text">Email Signup</span></div>
        		</a><a target="_blank" href="https://www.instagram.com/everettclipper/">
        		<div class="alt-header-social-fa social-border sno-instagram fa fa-instagram"><span class="icon-hidden-text">Instagram</span></div>
        	</a><a target="_blank" href="https://twitter.com/EverettClipper">
        		<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"><span class="icon-hidden-text">Twitter</span></div>
        	</a><a target="_blank" href="https://www.facebook.com/pages/The-Clipper/144917002154?ref=hl">
        		<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"><span class="icon-hidden-text">Facebook</span></div>
        	</a><div class="social-spacer"></div></div></div><div class="footertagline"><p>The student news site of Everett Community College in Everett, Washington</p></div><div class="footersearch">	<form method="get" id="searchform1926" action="https://everettclipper.com/">
			<div class="search-button-container" id="searchthis1926">
			<button type="submit" disabled="disabled" id="sno-search-navbar-1926" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s1926" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s1926" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit1926" style="display:none;" value="Search" />
		</form>
	</div><div class="clear"></div><div class="footermenu"><div class="menu-extra-pages-container"><ul id="menu-extra-pages" class="footer-menu"><li id="menu-item-170" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170"><a href="/">Home</a></li>
<li id="menu-item-171" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171"><a href="https://everettclipper.com/about/">About</a></li>
<li id="menu-item-4213" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4213"><a href="https://everettclipper.com/staff/">Staff</a></li>
<li id="menu-item-3155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3155"><a href="https://everettclipper.com/advertising/">Contact</a></li>
<li id="menu-item-5791" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5791"><a href="https://everettclipper.com/advertise/">Advertise</a></li>
</ul></div></div><div class="footercredit"><p>&copy; 2020  &bull; <a target='_blank' href='/'>Privacy Policy</a> &bull; <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://everettclipper.com/wp-login.php">Log in</a></p></div><div class="clear"></div></div></div>
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-49945470-15', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	<div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div><script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/everettclipper.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://everettclipper.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/everettclipper.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://everettclipper.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.5'></script>
<script type='text/javascript' src='https://everettclipper.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script async="async" type='text/javascript' src='https://everettclipper.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script>
</div></body></html>